Scopus compatibility issues with IE11

Scopus is experiencing compatibility issues with the latest version of Internet Explorer, IE11.  Until the issue is resolved, either use another browser or, in IE, go to Tools | Compatibility View Settings and add two websites: scopus.com & uchicago.edu.

This entry was posted in Science, Science E-resource Problems/Fixes. Bookmark the permalink.
  • Delicious
  • Facebook
  • RSS Feed
  • StumbleUpon
  • Twitter